aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/llvm/patches/100-darwin_arch_auto.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/llvm/patches/100-darwin_arch_auto.patch')
-rw-r--r--toolchain/llvm/patches/100-darwin_arch_auto.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/toolchain/llvm/patches/100-darwin_arch_auto.patch b/toolchain/llvm/patches/100-darwin_arch_auto.patch
new file mode 100644
index 000000000..a48e13121
--- /dev/null
+++ b/toolchain/llvm/patches/100-darwin_arch_auto.patch
@@ -0,0 +1,19 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -618,16 +618,6 @@ ifdef UNIVERSAL
+
+ # Building universal cannot compute dependencies automatically.
+ DISABLE_AUTO_DEPENDENCIES=1
+-else
+- ifeq ($(TARGET_OS),Darwin)
+- ifeq ($(ARCH),x86_64)
+- TargetCommonOpts = -m64
+- else
+- ifeq ($(ARCH),x86)
+- TargetCommonOpts = -m32
+- endif
+- endif
+- endif
+ endif
+
+ ifeq ($(HOST_OS),SunOS)