aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/patches
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gdb/patches')
-rw-r--r--toolchain/gdb/patches/100-ppc_compile_fix.patch11
-rw-r--r--toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch31
2 files changed, 42 insertions, 0 deletions
diff --git a/toolchain/gdb/patches/100-ppc_compile_fix.patch b/toolchain/gdb/patches/100-ppc_compile_fix.patch
new file mode 100644
index 000000000..4c5cb4efd
--- /dev/null
+++ b/toolchain/gdb/patches/100-ppc_compile_fix.patch
@@ -0,0 +1,11 @@
+--- a/sim/ppc/Makefile.in
++++ b/sim/ppc/Makefile.in
+@@ -551,7 +551,7 @@ PACKAGE_SRC = @sim_pk_src@
+ PACKAGE_OBJ = @sim_pk_obj@
+
+
+-psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBS) $(LIBINTL_DEP)
++psim: $(TARGETLIB) main.o $(LIBIBERTY_LIB) $(BFD_LIB) $(LIBINTL_DEP)
+ $(CC) $(CFLAGS) $(SIM_CFLAGS) $(LDFLAGS) -o psim$(EXEEXT) main.o $(TARGETLIB) $(BFD_LIB) $(LIBINTL) $(LIBIBERTY_LIB) $(LIBS)
+
+ run: psim
diff --git a/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
new file mode 100644
index 000000000..089ab8c5a
--- /dev/null
+++ b/toolchain/gdb/patches/600-fix-compile-flag-mismatch.patch
@@ -0,0 +1,31 @@
+--- a/gdb/configure
++++ b/gdb/configure
+@@ -988,7 +988,7 @@ CPP
+ YACC
+ YFLAGS
+ XMKMF'
+-ac_subdirs_all='doc testsuite
++ac_subdirs_all='doc
+ gdbtk
+ multi-ice
+ gdbserver'
+@@ -7881,7 +7881,7 @@ fi
+
+
+
+-subdirs="$subdirs doc testsuite"
++subdirs="$subdirs doc"
+
+
+ # Check whether to support alternative target configurations
+--- a/gdb/gdbserver/configure
++++ b/gdb/gdbserver/configure
+@@ -2152,7 +2152,7 @@ $as_echo "$as_me: error: \`$ac_var' was
+ ac_cache_corrupted=: ;;
+ ,);;
+ *)
+- if test "x$ac_old_val" != "x$ac_new_val"; then
++ if test "`echo x$ac_old_val`" != "`echo x$ac_new_val`"; then
+ # differences in whitespace do not lead to failure.
+ ac_old_val_w=`echo x $ac_old_val`
+ ac_new_val_w=`echo x $ac_new_val`