aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/llvm/960-apple_no_m32.patch
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/gcc/patches/llvm/960-apple_no_m32.patch')
-rw-r--r--toolchain/gcc/patches/llvm/960-apple_no_m32.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/toolchain/gcc/patches/llvm/960-apple_no_m32.patch b/toolchain/gcc/patches/llvm/960-apple_no_m32.patch
new file mode 100644
index 000000000..62376b381
--- /dev/null
+++ b/toolchain/gcc/patches/llvm/960-apple_no_m32.patch
@@ -0,0 +1,28 @@
+--- a/configure
++++ b/configure
+@@ -1833,11 +1833,6 @@ case "${host}" in
+ # APPLE LOCAL begin dynamic-no-pic
+ i[3456789]86-*-darwin*)
+ host_makefile_frag="config/mh-x86-darwin"
+- # gcc can default to x86_64 code generation, avoid that
+- if test "${build}" = "${host}"; then
+- CC="${CC-gcc} -m32"
+- CXX="${CXX-g++} -m32"
+- fi
+ ;;
+ # APPLE LOCAL end dynamic-no-pic
+ powerpc-*-aix*)
+--- a/configure.in
++++ b/configure.in
+@@ -993,11 +993,6 @@ case "${host}" in
+ # APPLE LOCAL begin dynamic-no-pic
+ i[[3456789]]86-*-darwin*)
+ host_makefile_frag="config/mh-x86-darwin"
+- # gcc can default to x86_64 code generation, avoid that
+- if test "${build}" = "${host}"; then
+- CC="${CC-gcc} -m32"
+- CXX="${CXX-g++} -m32"
+- fi
+ ;;
+ # APPLE LOCAL end dynamic-no-pic
+ powerpc-*-aix*)