aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'toolchain/eglibc/Makefile')
-rw-r--r--toolchain/eglibc/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
new file mode 100644
index 000000000..c975b7a2e
--- /dev/null
+++ b/toolchain/eglibc/Makefile
@@ -0,0 +1,26 @@
+PATH_PREFIX := .
+VARIANT:=final
+
+include ./common.mk
+
+define Host/Compile
+ $(MAKE) -C $(CUR_BUILD_DIR) all
+endef
+
+define Host/Install
+ $(call Host/SetToolchainInfo)
+ $(MAKE) -C $(CUR_BUILD_DIR) \
+ install_root="$(TOOLCHAIN_DIR)" \
+ install
+ ( cd $(TOOLCHAIN_DIR) ; \
+ for d in lib usr/lib ; do \
+ for f in libc.so libpthread.so libgcc_s.so ; do \
+ if [ -f $$$$d/$$$$f -a ! -L $$$$d/$$$$f ] ; then \
+ $(SED) 's,/usr/lib/,,g;s,/lib/,,g' $$$$d/$$$$f ; \
+ fi \
+ done \
+ done \
+ )
+endef
+
+$(eval $(call HostBuild))