aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/xburst/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/xburst/image/Makefile')
-rw-r--r--target/linux/xburst/image/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/xburst/image/Makefile b/target/linux/xburst/image/Makefile
new file mode 100644
index 000000000..9c03b3809
--- /dev/null
+++ b/target/linux/xburst/image/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=256k 512k
+
+ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBIFS_OPTS = -m 4096 -e 516096 -c 4095
+UBINIZE_OPTS = -m 4096 -p 512KiB
+else
+UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+endif
+
+UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin
+
+define kernel_entry
+0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
+endef
+
+
+define MkImageGzip
+ gzip -9 -c $(1) > $(1).gz
+ mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
+ -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+ -d $(1).gz $(2)
+endef
+
+define Image/BuildKernel
+ $(call MkImageGzip,$(KDIR)/vmlinux,$(UIMAGE))
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))