aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/x86/generic/profiles/000-Generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/x86/generic/profiles/000-Generic.mk')
-rw-r--r--target/linux/x86/generic/profiles/000-Generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/x86/generic/profiles/000-Generic.mk b/target/linux/x86/generic/profiles/000-Generic.mk
new file mode 100644
index 000000000..90f989a91
--- /dev/null
+++ b/target/linux/x86/generic/profiles/000-Generic.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic
+ PACKAGES:=kmod-3c59x kmod-e100 kmod-e1000 kmod-natsemi kmod-ne2k-pci \
+ kmod-pcnet32 kmod-8139too kmod-r8169 kmod-sis900 kmod-tg3 \
+ kmod-via-rhine kmod-via-velocity
+endef
+
+define Profile/Generic/Description
+ Generic Profile
+endef
+$(eval $(call Profile,Generic))