aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ubicom32/files/arch/ubicom32/mach-ip5k/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ubicom32/files/arch/ubicom32/mach-ip5k/Makefile')
-rw-r--r--target/linux/ubicom32/files/arch/ubicom32/mach-ip5k/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/ubicom32/files/arch/ubicom32/mach-ip5k/Makefile b/target/linux/ubicom32/files/arch/ubicom32/mach-ip5k/Makefile
new file mode 100644
index 000000000..d02f339bd
--- /dev/null
+++ b/target/linux/ubicom32/files/arch/ubicom32/mach-ip5k/Makefile
@@ -0,0 +1,31 @@
+#
+# arch/ubicom32/mach-ip5k/Makefile
+# Makefile for boards which have an ip5k on them.
+#
+# (C) Copyright 2009, Ubicom, Inc.
+#
+# This file is part of the Ubicom32 Linux Kernel Port.
+#
+# The Ubicom32 Linux Kernel Port is free software: you can redistribute
+# it and/or modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, either version 2 of the
+# License, or (at your option) any later version.
+#
+# The Ubicom32 Linux Kernel Port is distributed in the hope that it
+# will be useful, but WITHOUT ANY WARRANTY; without even the implied
+# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
+# the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with the Ubicom32 Linux Kernel Port. If not,
+# see <http://www.gnu.org/licenses/>.
+#
+# Ubicom32 implementation derived from (with many thanks):
+# arch/m68knommu
+# arch/blackfin
+# arch/parisc
+#
+
+obj-$(CONFIG_IP5170DPF) += board-ip5170dpf.o
+obj-$(CONFIG_IP5160DEV) += board-ip5160dev.o
+obj-$(CONFIG_IP5160EVAL) += board-ip5160rgw.o