aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realview/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/realview/Makefile')
-rw-r--r--target/linux/realview/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/realview/Makefile b/target/linux/realview/Makefile
new file mode 100644
index 000000000..5641aa62d
--- /dev/null
+++ b/target/linux/realview/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=realview
+BOARDNAME:=ARM Ltd. Realview board (qemu)
+FEATURES:=fpu ramdisk
+CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for ARM Ltd. Realview boards to be run with qemu
+endef
+
+KERNELNAME:="zImage"
+
+$(eval $(call BuildTarget))