aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rdc/profiles')
-rw-r--r--target/linux/rdc/profiles/ar525w.mk12
-rw-r--r--target/linux/rdc/profiles/bifferboard.mk13
-rw-r--r--target/linux/rdc/profiles/r8610.mk15
-rw-r--r--target/linux/rdc/profiles/sitecom.mk12
4 files changed, 52 insertions, 0 deletions
diff --git a/target/linux/rdc/profiles/ar525w.mk b/target/linux/rdc/profiles/ar525w.mk
new file mode 100644
index 000000000..d38cb1f23
--- /dev/null
+++ b/target/linux/rdc/profiles/ar525w.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ar525w
+ NAME:=Airlink AR525W
+ PACKAGES:=kmod-rt61-pci kmod-switch-ip17xx swconfig
+endef
+$(eval $(call Profile,ar525w))
diff --git a/target/linux/rdc/profiles/bifferboard.mk b/target/linux/rdc/profiles/bifferboard.mk
new file mode 100644
index 000000000..28e1d0e6d
--- /dev/null
+++ b/target/linux/rdc/profiles/bifferboard.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/bifferboard
+ NAME:=Bifferboard
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-usb-storage kmod-scsi-core kmod-fs-ext3
+endef
+$(eval $(call Profile,bifferboard))
diff --git a/target/linux/rdc/profiles/r8610.mk b/target/linux/rdc/profiles/r8610.mk
new file mode 100644
index 000000000..67fef8a5a
--- /dev/null
+++ b/target/linux/rdc/profiles/r8610.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/r8610
+ NAME:=RDC R8610 Evaluation Board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-hwmon-core kmod-hwmon-w83627hf kmod-ide-core kmod-ide-it821x \
+ kmod-rtc-core kmod-rtc-m48t86 \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+$(eval $(call Profile,r8610))
diff --git a/target/linux/rdc/profiles/sitecom.mk b/target/linux/rdc/profiles/sitecom.mk
new file mode 100644
index 000000000..e3b2981ed
--- /dev/null
+++ b/target/linux/rdc/profiles/sitecom.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/sitecom
+ NAME:=Devices from Sitecom (WL-153, DC-230)
+ PACKAGES:=kmod-rt61-pci kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,sitecom))