aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/patches-3.3/011-tune_lzma_options.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rdc/patches-3.3/011-tune_lzma_options.patch')
-rw-r--r--target/linux/rdc/patches-3.3/011-tune_lzma_options.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/rdc/patches-3.3/011-tune_lzma_options.patch b/target/linux/rdc/patches-3.3/011-tune_lzma_options.patch
new file mode 100644
index 000000000..e6fd44d4e
--- /dev/null
+++ b/target/linux/rdc/patches-3.3/011-tune_lzma_options.patch
@@ -0,0 +1,22 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -296,7 +296,7 @@ cmd_bzip2 = (cat $(filter-out FORCE,$^)
+
+ quiet_cmd_lzma = LZMA $@
+ cmd_lzma = (cat $(filter-out FORCE,$^) | \
+- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
++ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
+ (rm -f $@ ; false)
+
+ quiet_cmd_lzo = LZO $@
+--- a/arch/x86/include/asm/boot.h
++++ b/arch/x86/include/asm/boot.h
+@@ -28,7 +28,7 @@
+ #error "Invalid value for CONFIG_PHYSICAL_ALIGN"
+ #endif
+
+-#ifdef CONFIG_KERNEL_BZIP2
++#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
+ #define BOOT_HEAP_SIZE 0x400000
+ #else /* !CONFIG_KERNEL_BZIP2 */
+