aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/rdc/modules.mk')
-rw-r--r--target/linux/rdc/modules.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/rdc/modules.mk b/target/linux/rdc/modules.mk
new file mode 100644
index 000000000..ce7cbdf6e
--- /dev/null
+++ b/target/linux/rdc/modules.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/rdc321x-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=RDC321x watchdog
+ DEPENDS:=@TARGET_rdc
+ KCONFIG:=CONFIG_RDC321X_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+ RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+