aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch b/target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch
new file mode 100644
index 000000000..6a9cefa86
--- /dev/null
+++ b/target/linux/ramips/patches-3.3/104-ramips-watchdog-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1033,6 +1033,13 @@ config LANTIQ_WDT
+ help
+ Hardware driver for the Lantiq SoC Watchdog Timer.
+
++config RAMIPS_WDT
++ tristate "Ralink RT288X/RT305X Watchdog Timer"
++ depends on (SOC_RT288X || SOC_RT305X || SOC_RT3883)
++ help
++ Hardware driver for the built-in watchdog timer on the
++ Ralink RT288X/RT305X SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -132,6 +132,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+ obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
+
+ # PARISC Architecture
+