aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile')
-rw-r--r--target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile b/target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile
new file mode 100644
index 000000000..3068d58d2
--- /dev/null
+++ b/target/linux/ramips/files/arch/mips/ralink/rt3883/Makefile
@@ -0,0 +1,14 @@
+#
+# Makefile for the Ralink RT3662/RT3883 SoC specific parts of the kernel
+#
+# Copyright (C) 2011-2012 Gabor Juhos <juhosg@openwrt.org>
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License version 2 as published
+# by the Free Software Foundation.
+
+obj-y := irq.o setup.o devices.o rt3883.o clock.o
+
+obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+
+obj-$(CONFIG_RT3883_MACH_RT_N56U) += mach-rt-n56u.o