aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ramips/Makefile')
-rw-r--r--target/linux/ramips/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
new file mode 100644
index 000000000..e49ff41a1
--- /dev/null
+++ b/target/linux/ramips/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=ramips
+BOARDNAME:=Ralink RT288x/RT3xxx
+SUBTARGETS:=rt288x rt305x rt3883
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+FEATURES:=squashfs
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=\
+ kmod-leds-gpio kmod-input-core kmod-input-polldev \
+ kmod-input-gpio-keys-polled kmod-button-hotplug \
+ kmod-rt2800-pci wpad-mini maccalc swconfig
+
+define Target/Description
+ Build firmware images for Ralink RT288x/RT3xxx based boards.
+endef
+
+$(eval $(call BuildTarget))