aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxcab/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/pxcab/modules.mk')
-rw-r--r--target/linux/pxcab/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/pxcab/modules.mk b/target/linux/pxcab/modules.mk
new file mode 100644
index 000000000..0c5a254a9
--- /dev/null
+++ b/target/linux/pxcab/modules.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/axonram
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=Axon DDR2 memory device driver
+ DEPENDS:=@TARGET_pxcab
+ KCONFIG:=CONFIG_AXON_RAM
+ FILES:=$(LINUX_DIR)/arch/powerpc/sysdev/axonram.ko
+ AUTOLOAD:=$(call AutoLoad,01,axonram)
+endef
+
+define KernelPackage/axonram/description
+ Kernel support for Axon DDR2 memory device
+endef
+
+$(eval $(call KernelPackage,axonram))