aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxcab/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/pxcab/Makefile')
-rw-r--r--target/linux/pxcab/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/pxcab/Makefile b/target/linux/pxcab/Makefile
new file mode 100644
index 000000000..08ab70ff9
--- /dev/null
+++ b/target/linux/pxcab/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=pxcab
+BOARDNAME:=PowerXCell Accelerator Board
+FEATURES:=powerpc64 fpu ramdisk broken
+
+LINUX_VERSION:=2.6.30.10
+
+KERNEL_CC:=
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build zImage for the IBM PowerXCell Accelerator Board
+ (aka mvXCell-8i from MatrixVision or GigaAccel 180 from Fixstars)
+endef
+
+KERNELNAME:="zImage"
+
+DEFAULT_PACKAGES += kmod-tg3
+
+$(eval $(call BuildTarget))