aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/pxa/Makefile')
-rw-r--r--target/linux/pxa/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/pxa/Makefile b/target/linux/pxa/Makefile
new file mode 100644
index 000000000..cf6fe8916
--- /dev/null
+++ b/target/linux/pxa/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=pxa
+BOARDNAME:=Marvell/Intel PXA2xx
+FEATURES:=squashfs jffs2
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for PXA2xx systems, eg. Gumstix.
+endef
+
+KERNELNAME:="uImage"
+
+$(eval $(call BuildTarget))