aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/octeon/profiles')
-rw-r--r--target/linux/octeon/profiles/000-Generic.mk17
-rw-r--r--target/linux/octeon/profiles/100-Mototech.mk18
2 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/octeon/profiles/000-Generic.mk b/target/linux/octeon/profiles/000-Generic.mk
new file mode 100644
index 000000000..a08f85702
--- /dev/null
+++ b/target/linux/octeon/profiles/000-Generic.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/generic
+ NAME:=Generic Octeon board
+ PACKAGES:=kmod-ath9k
+endef
+
+define Profile/generic/Description
+ Base packages for Octeon boards.
+endef
+$(eval $(call Profile,generic))
+
diff --git a/target/linux/octeon/profiles/100-Mototech.mk b/target/linux/octeon/profiles/100-Mototech.mk
new file mode 100644
index 000000000..17e778b1d
--- /dev/null
+++ b/target/linux/octeon/profiles/100-Mototech.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/mototech
+ NAME:=Mototech evaluation board
+ PACKAGES:=kmod-ath9k kmod-ata-core kmod-ata-sil24 kmod-usb-core kmod-usb2 \
+ kmod-usb-octeon
+endef
+
+define Profile/mototech/Description
+ Package set compatible with the Mototech Evaluation Board (CN5000F).
+endef
+$(eval $(call Profile,mototech))
+