aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mpc52xx/Makefile')
-rw-r--r--target/linux/mpc52xx/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/mpc52xx/Makefile b/target/linux/mpc52xx/Makefile
new file mode 100644
index 000000000..a61f40c71
--- /dev/null
+++ b/target/linux/mpc52xx/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=mpc52xx
+BOARDNAME:=Freescale MPC52xx
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+FEATURES:=targz ext4
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build images for the Freescale MPC52xx based boards.
+endef
+
+$(eval $(call BuildTarget))