aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/modules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mcs814x/modules.mk')
-rw-r--r--target/linux/mcs814x/modules.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/mcs814x/modules.mk b/target/linux/mcs814x/modules.mk
new file mode 100644
index 000000000..c29ca860d
--- /dev/null
+++ b/target/linux/mcs814x/modules.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+define KernelPackage/mcs814x-wdt
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@TARGET_mcs814x
+ TITLE:=MCS814x watchdog driver
+ KCONFIG:=CONFIG_MCS814X_WATCHDOG
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/mcs814x_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,mcs814x_wdt)
+endef
+
+define KernelPackage/mcs814x-wdt/description
+ Kernel module for the Moschip MCS814x watchdog timer.
+endef
+
+$(eval $(call KernelPackage,mcs814x-wdt))