aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/mcs814x/Makefile')
-rw-r--r--target/linux/mcs814x/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/mcs814x/Makefile b/target/linux/mcs814x/Makefile
new file mode 100644
index 000000000..47569fe9d
--- /dev/null
+++ b/target/linux/mcs814x/Makefile
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=mcs814x
+BOARDNAME:=Moschip MCS814x
+FEATURES:=usb squashfs jffs2
+CFLAGS=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+DEVICE_TYPE:=other
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES)) \
+ kmod-usb-core kmod-usb2 kmod-usb-ohci \
+ kmod-usb-storage kmod-fs-vfat \
+ kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-iso8859-15 \
+ kmod-nls-utf8 \
+ kmod-mcs814x-wdt kmod-ledtrig-usbdev
+
+KERNELNAME:="zImage dtbs"
+
+$(eval $(call BuildTarget))