aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/malta/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/malta/Makefile')
-rw-r--r--target/linux/malta/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/malta/Makefile b/target/linux/malta/Makefile
new file mode 100644
index 000000000..172aeeca8
--- /dev/null
+++ b/target/linux/malta/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2010-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+BOARD:=malta
+BOARDNAME:=MIPS Malta CoreLV board (qemu)
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+SUBTARGETS:=le be
+INITRAMFS_EXTRA_FILES:=
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
+
+$(eval $(call BuildTarget))