aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/leon/image/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/leon/image/Makefile')
-rw-r--r--target/linux/leon/image/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/leon/image/Makefile b/target/linux/leon/image/Makefile
new file mode 100644
index 000000000..2be550e17
--- /dev/null
+++ b/target/linux/leon/image/Makefile
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/sparc/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ mkdir -p $(BIN_DIR)
+ cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
+endef
+
+$(eval $(call BuildImage))