aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/leon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/leon/Makefile')
-rw-r--r--target/linux/leon/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/leon/Makefile b/target/linux/leon/Makefile
new file mode 100644
index 000000000..dca32aaf7
--- /dev/null
+++ b/target/linux/leon/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=sparc
+BOARD:=leon
+BOARDNAME:=LEON
+FEATURES+=fpu tgz broken
+
+CFLAGS:=-Os -pipe -mcpu=v8 -fno-caller-saves
+KERNELNAME:="uImage"
+
+LINUX_VERSION:=2.6.36.4
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+DEVICE_TYPE:=developerboard
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))