aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/patches-3.3/0011-i2c-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/patches-3.3/0011-i2c-support.patch')
-rw-r--r--target/linux/lantiq/patches-3.3/0011-i2c-support.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/lantiq/patches-3.3/0011-i2c-support.patch b/target/linux/lantiq/patches-3.3/0011-i2c-support.patch
new file mode 100644
index 000000000..5d8bc279d
--- /dev/null
+++ b/target/linux/lantiq/patches-3.3/0011-i2c-support.patch
@@ -0,0 +1,46 @@
+From 5a39e76b3ea2f7dbf04f7dd2210536068583eaf6 Mon Sep 17 00:00:00 2001
+From: John Crispin <blogic@openwrt.org>
+Date: Fri, 3 Aug 2012 09:54:22 +0200
+Subject: [PATCH 11/25] i2c support
+
+---
+ drivers/i2c/busses/Kconfig | 10 ++++++++++
+ drivers/i2c/busses/Makefile | 1 +
+ 2 files changed, 11 insertions(+), 0 deletions(-)
+
+diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
+index 3101dd5..e8d149d 100644
+--- a/drivers/i2c/busses/Kconfig
++++ b/drivers/i2c/busses/Kconfig
+@@ -369,6 +369,16 @@ config I2C_DESIGNWARE_PCI
+ This driver can also be built as a module. If so, the module
+ will be called i2c-designware-pci.
+
++config I2C_FALCON
++ tristate "Falcon I2C interface"
++ depends on SOC_FALCON
++ help
++ If you say yes to this option, support will be included for the
++ Lantiq FALC-ON I2C core.
++
++ This driver can also be built as a module. If so, the module
++ will be called i2c-falcon.
++
+ config I2C_GPIO
+ tristate "GPIO-based bitbanging I2C"
+ depends on GENERIC_GPIO
+diff --git a/drivers/i2c/busses/Makefile b/drivers/i2c/busses/Makefile
+index fba6da6..36239c8 100644
+--- a/drivers/i2c/busses/Makefile
++++ b/drivers/i2c/busses/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_I2C_DESIGNWARE_PLATFORM) += i2c-designware-platform.o
+ i2c-designware-platform-objs := i2c-designware-platdrv.o i2c-designware-core.o
+ obj-$(CONFIG_I2C_DESIGNWARE_PCI) += i2c-designware-pci.o
+ i2c-designware-pci-objs := i2c-designware-pcidrv.o i2c-designware-core.o
++obj-$(CONFIG_I2C_FALCON) += i2c-falcon.o
+ obj-$(CONFIG_I2C_GPIO) += i2c-gpio.o
+ obj-$(CONFIG_I2C_HIGHLANDER) += i2c-highlander.o
+ obj-$(CONFIG_I2C_IBM_IIC) += i2c-ibm_iic.o
+--
+1.7.9.1
+