aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/falcon
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/falcon')
-rw-r--r--target/linux/lantiq/falcon/config-default20
-rw-r--r--target/linux/lantiq/falcon/profiles/000-generic.mk12
-rw-r--r--target/linux/lantiq/falcon/profiles/001-lantiq.mk24
-rw-r--r--target/linux/lantiq/falcon/target.mk13
4 files changed, 69 insertions, 0 deletions
diff --git a/target/linux/lantiq/falcon/config-default b/target/linux/lantiq/falcon/config-default
new file mode 100644
index 000000000..55231ea87
--- /dev/null
+++ b/target/linux/lantiq/falcon/config-default
@@ -0,0 +1,20 @@
+# CONFIG_ATMEL_PWM is not set
+CONFIG_CLKDEV_LOOKUP=y
+CONFIG_FSNOTIFY=y
+CONFIG_HAVE_MACH_CLKDEV=y
+CONFIG_IRQ_FORCED_THREADING=y
+CONFIG_M25PXX_USE_FAST_READ=y
+CONFIG_MDIO_BOARDINFO=y
+CONFIG_MTD_M25P80=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_PLATFORM=y
+# CONFIG_MTD_SM_COMMON is not set
+# CONFIG_SOC_AMAZON_SE is not set
+CONFIG_SOC_FALCON=y
+# CONFIG_SOC_TYPE_XWAY is not set
+# CONFIG_SOC_XWAY is not set
+# CONFIG_SOC_SVIP is not set
+CONFIG_SPI=y
+CONFIG_SPI_FALCON=y
+CONFIG_SPI_MASTER=y
diff --git a/target/linux/lantiq/falcon/profiles/000-generic.mk b/target/linux/lantiq/falcon/profiles/000-generic.mk
new file mode 100644
index 000000000..480e58eef
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/000-generic.mk
@@ -0,0 +1,12 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-falcon-lantiq kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25 \
+ gpon-dti-agent
+endef
+
+$(eval $(call Profile,Generic))
+
+
diff --git a/target/linux/lantiq/falcon/profiles/001-lantiq.mk b/target/linux/lantiq/falcon/profiles/001-lantiq.mk
new file mode 100644
index 000000000..fa42b62d1
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/001-lantiq.mk
@@ -0,0 +1,24 @@
+define Profile/EASY98000
+ NAME:=EASY98000
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+define Profile/EASY98000/Description
+ Lantiq EASY98000 evalkit
+endef
+
+$(eval $(call Profile,EASY98000))
+
+define Profile/EASY98020
+ NAME:=EASY98020
+endef
+
+define Profile/EASY98020/Description
+ Lantiq EASY98020 evalkit
+endef
+
+$(eval $(call Profile,EASY98020))
+
diff --git a/target/linux/lantiq/falcon/target.mk b/target/linux/lantiq/falcon/target.mk
new file mode 100644
index 000000000..eec3f5180
--- /dev/null
+++ b/target/linux/lantiq/falcon/target.mk
@@ -0,0 +1,13 @@
+ARCH:=mips
+SUBTARGET:=falcon
+BOARDNAME:=Falcon
+FEATURES:=squashfs jffs2
+DEVICE_TYPE:=other
+
+DEFAULT_PACKAGES+= kmod-ifxos gpon-base-files kmod-leds-gpio kmod-ledtrig-heartbeat \
+ kmod-gpon-optic-drv gpon-optic-drv kmod-gpon-onu-drv gpon-onu-drv \
+ gpon-pe-firmware gpon-omci-api gpon-omci-onu gpon-luci
+
+define Target/Description
+ Lantiq Falcon
+endef