aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/falcon/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/falcon/profiles')
-rw-r--r--target/linux/lantiq/falcon/profiles/000-generic.mk12
-rw-r--r--target/linux/lantiq/falcon/profiles/001-lantiq.mk24
2 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/lantiq/falcon/profiles/000-generic.mk b/target/linux/lantiq/falcon/profiles/000-generic.mk
new file mode 100644
index 000000000..480e58eef
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/000-generic.mk
@@ -0,0 +1,12 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-falcon-lantiq kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25 \
+ gpon-dti-agent
+endef
+
+$(eval $(call Profile,Generic))
+
+
diff --git a/target/linux/lantiq/falcon/profiles/001-lantiq.mk b/target/linux/lantiq/falcon/profiles/001-lantiq.mk
new file mode 100644
index 000000000..fa42b62d1
--- /dev/null
+++ b/target/linux/lantiq/falcon/profiles/001-lantiq.mk
@@ -0,0 +1,24 @@
+define Profile/EASY98000
+ NAME:=EASY98000
+ PACKAGES:= \
+ kmod-dm9000 \
+ kmod-i2c-core kmod-i2c-algo-bit kmod-i2c-gpio kmod-eeprom-at24 \
+ kmod-spi-bitbang kmod-spi-gpio kmod-eeprom-at25
+endef
+
+define Profile/EASY98000/Description
+ Lantiq EASY98000 evalkit
+endef
+
+$(eval $(call Profile,EASY98000))
+
+define Profile/EASY98020
+ NAME:=EASY98020
+endef
+
+define Profile/EASY98020/Description
+ Lantiq EASY98020 evalkit
+endef
+
+$(eval $(call Profile,EASY98020))
+