aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/danube/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/lantiq/danube/profiles')
-rw-r--r--target/linux/lantiq/danube/profiles/000-generic.mk5
-rw-r--r--target/linux/lantiq/danube/profiles/001-lantiq.mk10
-rw-r--r--target/linux/lantiq/danube/profiles/002-arcadyan.mk135
-rw-r--r--target/linux/lantiq/danube/profiles/003-gigaset.mk12
-rw-r--r--target/linux/lantiq/danube/profiles/004-bt.mk23
5 files changed, 185 insertions, 0 deletions
diff --git a/target/linux/lantiq/danube/profiles/000-generic.mk b/target/linux/lantiq/danube/profiles/000-generic.mk
new file mode 100644
index 000000000..a8346a746
--- /dev/null
+++ b/target/linux/lantiq/danube/profiles/000-generic.mk
@@ -0,0 +1,5 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+endef
+
+$(eval $(call Profile,Generic))
diff --git a/target/linux/lantiq/danube/profiles/001-lantiq.mk b/target/linux/lantiq/danube/profiles/001-lantiq.mk
new file mode 100644
index 000000000..43e5de500
--- /dev/null
+++ b/target/linux/lantiq/danube/profiles/001-lantiq.mk
@@ -0,0 +1,10 @@
+define Profile/EASY50712
+ NAME:=EASY50712
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg
+endef
+
+define Profile/EASY50712/Description
+ Lantiq EASY50712 evalkit
+endef
+
+$(eval $(call Profile,EASY50712))
diff --git a/target/linux/lantiq/danube/profiles/002-arcadyan.mk b/target/linux/lantiq/danube/profiles/002-arcadyan.mk
new file mode 100644
index 000000000..9d6011f68
--- /dev/null
+++ b/target/linux/lantiq/danube/profiles/002-arcadyan.mk
@@ -0,0 +1,135 @@
+define Profile/ARV3527P
+ NAME:=ARV3527P - Arcor Easybox 401
+ PACKAGES:=kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV3527P/Description
+ Package set optimized for the ARV3527P
+endef
+
+$(eval $(call Profile,ARV3527P))
+
+define Profile/ARV4510PW
+ NAME:=ARV4510PW - Wippies Homebox
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-rt61-pci wpad-mini \
+ kmod-ltq-dsl-firmware-a-danube
+endef
+
+define Profile/ARV4510PW/Description
+ Package set optimized for the ARV4518PW
+endef
+
+$(eval $(call Profile,ARV4510PW))
+
+define Profile/ARV4518PW
+ NAME:=ARV4518PW - SMC7908A
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath5k wpad-mini \
+ kmod-ltq-dsl-firmware-a-danube
+endef
+
+define Profile/ARV4518PW/Description
+ Package set optimized for the ARV4518PW
+endef
+
+$(eval $(call Profile,ARV4518PW))
+
+define Profile/ARV4519PW
+ NAME:=ARV4519PW - Vodafone, Pirelli
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath5k wpad-mini kmod-ltq-dsl-firmware-a-danube
+endef
+
+define Profile/ARV4519PW/Description
+ Package set optimized for the ARV4519PW
+endef
+
+$(eval $(call Profile,ARV4519PW))
+
+define Profile/ARV4520PW
+ NAME:=ARV4520PW - Arcor Easybox 800
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-rt61-pci wpad-mini \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV4520PW/Description
+ Package set optimized for the ARV4520PW
+endef
+
+$(eval $(call Profile,ARV4520PW))
+
+define Profile/ARV4525PW
+ NAME:=ARV4525PW - Speedport W502V
+ PACKAGES:=kmod-ath5k wpad-mini \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV4525PW/Description
+ Package set optimized for the ARV4525PW
+endef
+
+$(eval $(call Profile,ARV4525PW))
+
+define Profile/ARV7525PW
+ NAME:=ARV7525PW - Speedport W303V Typ A
+ PACKAGES:= kmod-rt2800-pci wpad-mini \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV7525PW/Description
+ Package set optimized for the ARV4525PW
+endef
+
+$(eval $(call Profile,ARV7525PW))
+
+define Profile/ARV452CPW
+ NAME:=ARV452CPW - Arcor Easybox 801
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath5k wpad-mini \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV452CPW/Description
+ Package set optimized for the ARV452CPW
+endef
+
+$(eval $(call Profile,ARV452CPW))
+
+define Profile/ARV752DPW
+ NAME:=ARV752DPW - Arcor Easybox 802
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-rt2800-pci wpad-mini \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV752DPW/Description
+ Package set optimized for the ARV752PW
+endef
+
+$(eval $(call Profile,ARV752DPW))
+
+define Profile/ARV752DPW22
+ NAME:=ARV752DPW22 - Arcor Easybox 803
+ PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-uhci kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/ARV752DPW22/Description
+ Package set optimized for the ARV752PW22
+endef
+
+$(eval $(call Profile,ARV752DPW22))
+
+define Profile/ARV7518PW
+ NAME:=ARV7518PW - ya.com, Astoria
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini kmod-ltq-dsl-firmware-a-danube
+endef
+
+define Profile/ARV7518PW/Description
+ Package set optimized for the ARV7518PW
+endef
+
+$(eval $(call Profile,ARV7518PW))
diff --git a/target/linux/lantiq/danube/profiles/003-gigaset.mk b/target/linux/lantiq/danube/profiles/003-gigaset.mk
new file mode 100644
index 000000000..feebd6417
--- /dev/null
+++ b/target/linux/lantiq/danube/profiles/003-gigaset.mk
@@ -0,0 +1,12 @@
+define Profile/GIGASX76X
+ NAME:=GIGASX76X - Gigaset SX761,SX762,SX763
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath5k wpad-mini kmod-ltq-dsl-firmware-a-danube \
+ kmod-ltq-dsl-firmware-b-danube
+endef
+
+define Profile/GIGASX76X/Description
+ Package set optimized for the Gigaset SX76X routers
+endef
+
+$(eval $(call Profile,GIGASX76X))
diff --git a/target/linux/lantiq/danube/profiles/004-bt.mk b/target/linux/lantiq/danube/profiles/004-bt.mk
new file mode 100644
index 000000000..26dd93c4b
--- /dev/null
+++ b/target/linux/lantiq/danube/profiles/004-bt.mk
@@ -0,0 +1,23 @@
+define Profile/BTHOMEHUBV2B
+ NAME:=BTHOMEHUBV2B - BT Homehub V2.0 Type B
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini kmod-ltq-dsl-firmware-a-danube
+endef
+
+define Profile/BTHOMEHUBV2B/Description
+ Package set optimized for the BT Homehub V2.0 Type B using whole nand for OpenWRT
+endef
+
+$(eval $(call Profile,BTHOMEHUBV2B))
+
+define Profile/BTHOMEHUBV2BOPENRG
+ NAME:=BTHOMEHUBV2B - BT Homehub V2.0 Type B (OpenRG)
+ PACKAGES:= kmod-usb-core kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+ kmod-ath9k wpad-mini kmod-ltq-dsl-firmware-a-danube
+endef
+
+define Profile/BTHOMEHUBV2BOPENRG/Description
+ Package set optimized for the BT Homehub V2.0 Type B but retaining OpenRG image
+endef
+
+$(eval $(call Profile,BTHOMEHUBV2BOPENRG))