aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ixp4xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ixp4xx/Makefile')
-rw-r--r--target/linux/ixp4xx/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ixp4xx/Makefile b/target/linux/ixp4xx/Makefile
new file mode 100644
index 000000000..58f3ec811
--- /dev/null
+++ b/target/linux/ixp4xx/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=armeb
+BOARD:=ixp4xx
+BOARDNAME:=Intel IXP4xx
+FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic harddisk
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+
+$(eval $(call BuildTarget))