aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/goldfish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/goldfish/Makefile')
-rw-r--r--target/linux/goldfish/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/goldfish/Makefile b/target/linux/goldfish/Makefile
new file mode 100644
index 000000000..dae4c3e30
--- /dev/null
+++ b/target/linux/goldfish/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=goldfish
+BOARDNAME:=Goldfish (Android Emulator)
+FEATURES:=broken
+CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -fno-caller-saves
+
+LINUX_VERSION:=2.6.30.10
+
+DEVICE_TYPE=phone
+
+define Target/Description
+ Android emulator virtual platform
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))