aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/generic/patches-3.3/202-reduce_module_size.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/generic/patches-3.3/202-reduce_module_size.patch')
-rw-r--r--target/linux/generic/patches-3.3/202-reduce_module_size.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/generic/patches-3.3/202-reduce_module_size.patch b/target/linux/generic/patches-3.3/202-reduce_module_size.patch
new file mode 100644
index 000000000..bca1e356a
--- /dev/null
+++ b/target/linux/generic/patches-3.3/202-reduce_module_size.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -374,7 +374,7 @@ KBUILD_CFLAGS_KERNEL :=
+ KBUILD_AFLAGS := -D__ASSEMBLY__
+ KBUILD_AFLAGS_MODULE := -DMODULE
+ KBUILD_CFLAGS_MODULE := -DMODULE
+-KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
++KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+
+ # Read KERNELRELEASE from include/config/kernel.release (if it exists)
+ KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)