aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches-3.3/022-MIPS-BCM63XX-Move-flash-registration-out-of-board_bc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/patches-3.3/022-MIPS-BCM63XX-Move-flash-registration-out-of-board_bc.patch')
-rw-r--r--target/linux/brcm63xx/patches-3.3/022-MIPS-BCM63XX-Move-flash-registration-out-of-board_bc.patch202
1 files changed, 202 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/patches-3.3/022-MIPS-BCM63XX-Move-flash-registration-out-of-board_bc.patch b/target/linux/brcm63xx/patches-3.3/022-MIPS-BCM63XX-Move-flash-registration-out-of-board_bc.patch
new file mode 100644
index 000000000..e9c85a2a6
--- /dev/null
+++ b/target/linux/brcm63xx/patches-3.3/022-MIPS-BCM63XX-Move-flash-registration-out-of-board_bc.patch
@@ -0,0 +1,202 @@
+From bfe47f0f68b5f7a3a92d07266cba58b188fe10e7 Mon Sep 17 00:00:00 2001
+From: Jonas Gorski <jonas.gorski@gmail.com>
+Date: Tue, 12 Jun 2012 10:23:38 +0200
+Subject: [PATCH 1/8] MIPS: BCM63XX: Move flash registration out of board_bcm963xx.c
+
+board_bcm963xx.c is already large enough.
+
+Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
+Cc: linux-mips@linux-mips.org
+Cc: Maxime Bizon <mbizon@freebox.fr>
+Cc: Florian Fainelli <florian@openwrt.org>
+Cc: Kevin Cernekee <cernekee@gmail.com>
+Patchwork: https://patchwork.linux-mips.org/patch/3952/
+Reviewed-by: Florian Fainelli <florian@openwrt.org>
+Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
+---
+ arch/mips/bcm63xx/Makefile | 4 +-
+ arch/mips/bcm63xx/boards/board_bcm963xx.c | 49 +-------------
+ arch/mips/bcm63xx/dev-flash.c | 69 ++++++++++++++++++++
+ .../include/asm/mach-bcm63xx/bcm63xx_dev_flash.h | 6 ++
+ 4 files changed, 79 insertions(+), 49 deletions(-)
+ create mode 100644 arch/mips/bcm63xx/dev-flash.c
+ create mode 100644 arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_flash.h
+
+--- a/arch/mips/bcm63xx/Makefile
++++ b/arch/mips/bcm63xx/Makefile
+@@ -1,6 +1,6 @@
+ obj-y += clk.o cpu.o cs.o gpio.o irq.o prom.o setup.o timer.o \
+- dev-dsp.o dev-enet.o dev-pcmcia.o dev-rng.o dev-spi.o \
+- dev-uart.o dev-wdt.o
++ dev-dsp.o dev-enet.o dev-flash.o dev-pcmcia.o dev-rng.o \
++ dev-spi.o dev-uart.o dev-wdt.o
+ obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
+
+ obj-y += boards/
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -11,9 +11,6 @@
+ #include <linux/kernel.h>
+ #include <linux/string.h>
+ #include <linux/platform_device.h>
+-#include <linux/mtd/mtd.h>
+-#include <linux/mtd/partitions.h>
+-#include <linux/mtd/physmap.h>
+ #include <linux/ssb/ssb.h>
+ #include <asm/addrspace.h>
+ #include <bcm63xx_board.h>
+@@ -24,6 +21,7 @@
+ #include <bcm63xx_dev_pci.h>
+ #include <bcm63xx_dev_enet.h>
+ #include <bcm63xx_dev_dsp.h>
++#include <bcm63xx_dev_flash.h>
+ #include <bcm63xx_dev_pcmcia.h>
+ #include <bcm63xx_dev_spi.h>
+ #include <board_bcm963xx.h>
+@@ -809,40 +807,6 @@ void __init board_setup(void)
+ panic("unexpected CPU for bcm963xx board");
+ }
+
+-static struct mtd_partition mtd_partitions[] = {
+- {
+- .name = "cfe",
+- .offset = 0x0,
+- .size = 0x40000,
+- }
+-};
+-
+-static const char *bcm63xx_part_types[] = { "bcm63xxpart", NULL };
+-
+-static struct physmap_flash_data flash_data = {
+- .width = 2,
+- .nr_parts = ARRAY_SIZE(mtd_partitions),
+- .parts = mtd_partitions,
+- .part_probe_types = bcm63xx_part_types,
+-};
+-
+-static struct resource mtd_resources[] = {
+- {
+- .start = 0, /* filled at runtime */
+- .end = 0, /* filled at runtime */
+- .flags = IORESOURCE_MEM,
+- }
+-};
+-
+-static struct platform_device mtd_dev = {
+- .name = "physmap-flash",
+- .resource = mtd_resources,
+- .num_resources = ARRAY_SIZE(mtd_resources),
+- .dev = {
+- .platform_data = &flash_data,
+- },
+-};
+-
+ static struct gpio_led_platform_data bcm63xx_led_data;
+
+ static struct platform_device bcm63xx_gpio_leds = {
+@@ -856,8 +820,6 @@ static struct platform_device bcm63xx_gp
+ */
+ int __init board_register_devices(void)
+ {
+- u32 val;
+-
+ if (board.has_uart0)
+ bcm63xx_uart_register(0);
+
+@@ -893,14 +855,7 @@ int __init board_register_devices(void)
+
+ bcm63xx_spi_register();
+
+- /* read base address of boot chip select (0) */
+- val = bcm_mpi_readl(MPI_CSBASE_REG(0));
+- val &= MPI_CSBASE_BASE_MASK;
+-
+- mtd_resources[0].start = val;
+- mtd_resources[0].end = 0x1FFFFFFF;
+-
+- platform_device_register(&mtd_dev);
++ bcm63xx_flash_register();
+
+ bcm63xx_led_data.num_leds = ARRAY_SIZE(board.leds);
+ bcm63xx_led_data.leds = board.leds;
+--- /dev/null
++++ b/arch/mips/bcm63xx/dev-flash.c
+@@ -0,0 +1,69 @@
++/*
++ * Broadcom BCM63xx flash registration
++ *
++ * This file is subject to the terms and conditions of the GNU General Public
++ * License. See the file "COPYING" in the main directory of this archive
++ * for more details.
++ *
++ * Copyright (C) 2008 Maxime Bizon <mbizon@freebox.fr>
++ * Copyright (C) 2008 Florian Fainelli <florian@openwrt.org>
++ */
++
++#include <linux/init.h>
++#include <linux/kernel.h>
++#include <linux/platform_device.h>
++#include <linux/mtd/mtd.h>
++#include <linux/mtd/partitions.h>
++#include <linux/mtd/physmap.h>
++
++#include <bcm63xx_cpu.h>
++#include <bcm63xx_dev_flash.h>
++#include <bcm63xx_regs.h>
++#include <bcm63xx_io.h>
++
++static struct mtd_partition mtd_partitions[] = {
++ {
++ .name = "cfe",
++ .offset = 0x0,
++ .size = 0x40000,
++ }
++};
++
++static const char *bcm63xx_part_types[] = { "bcm63xxpart", NULL };
++
++static struct physmap_flash_data flash_data = {
++ .width = 2,
++ .parts = mtd_partitions,
++ .part_probe_types = bcm63xx_part_types,
++};
++
++static struct resource mtd_resources[] = {
++ {
++ .start = 0, /* filled at runtime */
++ .end = 0, /* filled at runtime */
++ .flags = IORESOURCE_MEM,
++ }
++};
++
++static struct platform_device mtd_dev = {
++ .name = "physmap-flash",
++ .resource = mtd_resources,
++ .num_resources = ARRAY_SIZE(mtd_resources),
++ .dev = {
++ .platform_data = &flash_data,
++ },
++};
++
++int __init bcm63xx_flash_register(void)
++{
++ u32 val;
++
++ /* read base address of boot chip select (0) */
++ val = bcm_mpi_readl(MPI_CSBASE_REG(0));
++ val &= MPI_CSBASE_BASE_MASK;
++
++ mtd_resources[0].start = val;
++ mtd_resources[0].end = 0x1FFFFFFF;
++
++ return platform_device_register(&mtd_dev);
++}
+--- /dev/null
++++ b/arch/mips/include/asm/mach-bcm63xx/bcm63xx_dev_flash.h
+@@ -0,0 +1,6 @@
++#ifndef __BCM63XX_FLASH_H
++#define __BCM63XX_FLASH_H
++
++int __init bcm63xx_flash_register(void);
++
++#endif /* __BCM63XX_FLASH_H */