aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/brcm63xx/Makefile')
-rw-r--r--target/linux/brcm63xx/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/Makefile b/target/linux/brcm63xx/Makefile
new file mode 100644
index 000000000..098820f40
--- /dev/null
+++ b/target/linux/brcm63xx/Makefile
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=brcm63xx
+BOARDNAME:=Broadcom BCM63xx
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=3.3.8
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += kmod-switch kmod-input-gpio-keys-polled \
+ kmod-button-hotplug
+
+define Target/Description
+ Build firmware images for Broadcom based xDSL/routers
+ currently supports BCM6338, BCM6348 and BCM6358 based devices.
+ (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
+endef
+
+$(eval $(call BuildTarget))