aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/avr32/image/u-boot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/avr32/image/u-boot/Makefile')
-rw-r--r--target/linux/avr32/image/u-boot/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/avr32/image/u-boot/Makefile b/target/linux/avr32/image/u-boot/Makefile
new file mode 100644
index 000000000..6775d1d7c
--- /dev/null
+++ b/target/linux/avr32/image/u-boot/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2008-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2011.06
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=0cc5026aad02f218a9b9ac56b301c97a
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/package.mk
+
+UBOOT_CONFIG=$(call qstrip,$(CONFIG_AVR32_UBOOT_TARGET))
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+ $(MAKE) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
+endef
+
+define Build/InstallDev
+ mkdir -p $(BIN_DIR)
+ dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(PKG_VERSION)-$(UBOOT_CONFIG).bin bs=64k conv=sync
+endef
+
+$(eval $(call Build/DefaultTargets))