aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/atheros/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/atheros/Makefile')
-rw-r--r--target/linux/atheros/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
new file mode 100644
index 000000000..ce2a90dc9
--- /dev/null
+++ b/target/linux/atheros/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=atheros
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs jffs2
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k gpioctl swconfig
+
+define Target/Description
+ Build firmware images for Atheros SoC boards
+endef
+
+$(eval $(call BuildTarget))