aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/patches
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/patches')
-rw-r--r--target/linux/at91/patches/700-tqma9263-support.patch25
-rw-r--r--target/linux/at91/patches/805-free_some_portc_pins.patch11
-rw-r--r--target/linux/at91/patches/900-AT91-Add-external-RTC-for-Flexibity-board.patch35
-rw-r--r--target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch60
4 files changed, 131 insertions, 0 deletions
diff --git a/target/linux/at91/patches/700-tqma9263-support.patch b/target/linux/at91/patches/700-tqma9263-support.patch
new file mode 100644
index 000000000..321fe59a4
--- /dev/null
+++ b/target/linux/at91/patches/700-tqma9263-support.patch
@@ -0,0 +1,25 @@
+--- a/arch/arm/mach-at91/Kconfig
++++ b/arch/arm/mach-at91/Kconfig
+@@ -335,6 +335,12 @@ config MACH_NEOCORE926
+ help
+ Select this if you are using the Adeneo Neocore 926 board.
+
++config MACH_TQMA9263
++ bool "TQ Components TQMa9263 board"
++ help
++ Select this if you are using the an TQ Components TQMa9263 board.
++ <http://www.tq-components.com/>
++
+ endif
+
+ # ----------------------------------------------------------
+--- a/arch/arm/mach-at91/Makefile
++++ b/arch/arm/mach-at91/Makefile
+@@ -58,6 +58,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
+ obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
+ obj-$(CONFIG_MACH_USB_A9263) += board-usb-a926x.o
+ obj-$(CONFIG_MACH_NEOCORE926) += board-neocore926.o
++obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
+
+ # AT91SAM9RL board-specific support
+ obj-$(CONFIG_MACH_AT91SAM9RLEK) += board-sam9rlek.o
diff --git a/target/linux/at91/patches/805-free_some_portc_pins.patch b/target/linux/at91/patches/805-free_some_portc_pins.patch
new file mode 100644
index 000000000..df8e50a03
--- /dev/null
+++ b/target/linux/at91/patches/805-free_some_portc_pins.patch
@@ -0,0 +1,11 @@
+--- a/arch/arm/mach-at91/at91sam9260_devices.c
++++ b/arch/arm/mach-at91/at91sam9260_devices.c
+@@ -579,7 +579,7 @@ static struct platform_device at91sam926
+ .num_resources = ARRAY_SIZE(spi1_resources),
+ };
+
+-static const unsigned spi1_standard_cs[4] = { AT91_PIN_PB3, AT91_PIN_PC5, AT91_PIN_PC4, AT91_PIN_PC3 };
++static const unsigned spi1_standard_cs[2] = { AT91_PIN_PB3, AT91_PIN_PC5 };
+
+ void __init at91_add_device_spi(struct spi_board_info *devices, int nr_devices)
+ {
diff --git a/target/linux/at91/patches/900-AT91-Add-external-RTC-for-Flexibity-board.patch b/target/linux/at91/patches/900-AT91-Add-external-RTC-for-Flexibity-board.patch
new file mode 100644
index 000000000..2b67be1e4
--- /dev/null
+++ b/target/linux/at91/patches/900-AT91-Add-external-RTC-for-Flexibity-board.patch
@@ -0,0 +1,35 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -1,7 +1,7 @@
+ /*
+ * linux/arch/arm/mach-at91/board-flexibity.c
+ *
+- * Copyright (C) 2010 Flexibity
++ * Copyright (C) 2010-2011 Flexibity
+ * Copyright (C) 2005 SAN People
+ * Copyright (C) 2006 Atmel
+ *
+@@ -62,6 +62,13 @@ static struct at91_udc_data __initdata f
+ .pullup_pin = -EINVAL, /* pull-up driven by UDC */
+ };
+
++/* I2C devices */
++static struct i2c_board_info __initdata flexibity_i2c_devices[] = {
++ {
++ I2C_BOARD_INFO("ds1307", 0x68),
++ },
++};
++
+ /* SPI devices */
+ static struct spi_board_info flexibity_spi_devices[] = {
+ { /* DataFlash chip */
+@@ -141,6 +148,9 @@ static void __init flexibity_board_init(
+ at91_add_device_usbh(&flexibity_usbh_data);
+ /* USB Device */
+ at91_add_device_udc(&flexibity_udc_data);
++ /* I2C */
++ at91_add_device_i2c(flexibity_i2c_devices,
++ ARRAY_SIZE(flexibity_i2c_devices));
+ /* SPI */
+ at91_add_device_spi(flexibity_spi_devices,
+ ARRAY_SIZE(flexibity_spi_devices));
diff --git a/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
new file mode 100644
index 000000000..59f9bb30e
--- /dev/null
+++ b/target/linux/at91/patches/901-AT91-flexibity-default-leds-to-heartbeat.patch
@@ -0,0 +1,60 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -94,49 +94,49 @@ static struct gpio_led flexibity_leds[]
+ .name = "usb1:green",
+ .gpio = AT91_PIN_PA12,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb1:red",
+ .gpio = AT91_PIN_PA13,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb2:green",
+ .gpio = AT91_PIN_PB26,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb2:red",
+ .gpio = AT91_PIN_PB27,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb3:green",
+ .gpio = AT91_PIN_PC8,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb3:red",
+ .gpio = AT91_PIN_PC6,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb4:green",
+ .gpio = AT91_PIN_PB4,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ },
+ {
+ .name = "usb4:red",
+ .gpio = AT91_PIN_PB5,
+ .active_low = 1,
+- .default_trigger = "default-on",
++ .default_trigger = "heartbeat",
+ }
+ };
+