aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/Makefile')
-rw-r--r--target/linux/at91/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/at91/Makefile b/target/linux/at91/Makefile
new file mode 100644
index 000000000..3c7d85bda
--- /dev/null
+++ b/target/linux/at91/Makefile
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=at91
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
+BOARDNAME:=Atmel AT91
+FEATURES:=squashfs jffs2 targz ext2 usb
+CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
+SUBTARGETS:=9g20 9260 9263
+
+LINUX_VERSION:=3.3.8
+DEVICE_TYPE=
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= kmod-usb-ohci
+KERNELNAME:="uImage"
+
+$(eval $(call BuildTarget))