aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/9260
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/9260')
-rw-r--r--target/linux/at91/9260/base-files/etc/config/network20
-rw-r--r--target/linux/at91/9260/base-files/etc/config/system9
-rw-r--r--target/linux/at91/9260/base-files/etc/init.d/custom-user-startup22
-rw-r--r--target/linux/at91/9260/config-default12
-rw-r--r--target/linux/at91/9260/profiles/000-flexibity-minimal.mk18
-rw-r--r--target/linux/at91/9260/profiles/001-flexibity-xwrt.mk26
-rw-r--r--target/linux/at91/9260/profiles/002-flexibity-luci.mk26
-rw-r--r--target/linux/at91/9260/target.mk16
8 files changed, 149 insertions, 0 deletions
diff --git a/target/linux/at91/9260/base-files/etc/config/network b/target/linux/at91/9260/base-files/etc/config/network
new file mode 100644
index 000000000..5800a0bff
--- /dev/null
+++ b/target/linux/at91/9260/base-files/etc/config/network
@@ -0,0 +1,20 @@
+
+config 'interface' 'loopback'
+ option 'ifname' 'lo'
+ option 'proto' 'static'
+ option 'ipaddr' '127.0.0.1'
+ option 'netmask' '255.0.0.0'
+
+config 'interface' 'cfg'
+ option 'ifname' 'usb0'
+ option 'proto' 'static'
+ option 'netmask' '255.255.255.0'
+ option 'gateway' '192.168.119.1'
+ option 'ipaddr' '192.168.119.2'
+
+config 'interface' 'lan'
+ option 'ifname' 'wlan0'
+ option 'proto' 'dhcp'
+
+#config 'interface' 'wan'
+# option
diff --git a/target/linux/at91/9260/base-files/etc/config/system b/target/linux/at91/9260/base-files/etc/config/system
new file mode 100644
index 000000000..ba7e87c62
--- /dev/null
+++ b/target/linux/at91/9260/base-files/etc/config/system
@@ -0,0 +1,9 @@
+config 'system'
+ option 'timezone' 'UTC'
+ option 'hostname' 'flexibity'
+
+config timeserver ntp
+ list server 0.openwrt.pool.ntp.org
+ list server 1.openwrt.pool.ntp.org
+ list server 2.openwrt.pool.ntp.org
+ list server 3.openwrt.pool.ntp.org
diff --git a/target/linux/at91/9260/base-files/etc/init.d/custom-user-startup b/target/linux/at91/9260/base-files/etc/init.d/custom-user-startup
new file mode 100644
index 000000000..dc9f77c98
--- /dev/null
+++ b/target/linux/at91/9260/base-files/etc/init.d/custom-user-startup
@@ -0,0 +1,22 @@
+#!/bin/sh /etc/rc.common
+START=90
+# place your own startup commands here
+#
+# REMEMBER: You *MUST* place an '&' after launching programs you
+# that are to continue running in the background.
+#
+# i.e.
+# BAD: upnpd
+# GOOD: upnpd &
+#
+# Failure to do this will result in the startup process halting
+# on this file and the diagnostic light remaining on (at least
+# for WRT54G(s) models).
+#
+
+# coldplug USB devices
+udevtrigger &
+
+# wait for coldplug and re-generate wireless config
+#wifi detect > /etc/config/wireless &
+
diff --git a/target/linux/at91/9260/config-default b/target/linux/at91/9260/config-default
new file mode 100644
index 000000000..b15515792
--- /dev/null
+++ b/target/linux/at91/9260/config-default
@@ -0,0 +1,12 @@
+CONFIG_ARCH_AT91SAM9260=y
+# CONFIG_MACH_AFEB9260 is not set
+# CONFIG_MACH_AT91SAM9260EK is not set
+# CONFIG_MACH_CAM60 is not set
+# CONFIG_MACH_CPU9260 is not set
+CONFIG_MACH_FLEXIBITY=y
+CONFIG_MACH_NO_WESTBRIDGE=y
+# CONFIG_MACH_QIL_A9260 is not set
+# CONFIG_MACH_SAM9_L9260 is not set
+# CONFIG_MACH_SNAPPER_9260 is not set
+# CONFIG_MACH_USB_A9260 is not set
+
diff --git a/target/linux/at91/9260/profiles/000-flexibity-minimal.mk b/target/linux/at91/9260/profiles/000-flexibity-minimal.mk
new file mode 100644
index 000000000..f8e7a6514
--- /dev/null
+++ b/target/linux/at91/9260/profiles/000-flexibity-minimal.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 20011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/flexibity-minimal
+ NAME:=Flexibity Connect (minimal)
+ PACKAGES:=
+endef
+
+define Profile/flexibity-minimal/Description
+ Minimal packages set for the Flexibity Connect device.
+endef
+
+$(eval $(call Profile,flexibity-minimal))
+
diff --git a/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk b/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
new file mode 100644
index 000000000..b1c526929
--- /dev/null
+++ b/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/flexibity-xwrt
+ NAME:=Flexibity Connect (XWrt)
+ PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev webif webif-applications webif-flexibity \
+ syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
+ iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
+ usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
+ fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
+ gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
+ file flock gdbserver gnupg gpioctl gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
+ module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
+ usb-modeswitch usb-modeswitch-data usbutils lua
+endef
+
+define Profile/flexibity-xwrt/Description
+ Complete packages set for the Flexibity Connect device (XWrt).
+endef
+
+$(eval $(call Profile,flexibity-xwrt))
+
diff --git a/target/linux/at91/9260/profiles/002-flexibity-luci.mk b/target/linux/at91/9260/profiles/002-flexibity-luci.mk
new file mode 100644
index 000000000..433239be6
--- /dev/null
+++ b/target/linux/at91/9260/profiles/002-flexibity-luci.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/flexibity-luci
+ NAME:=Flexibity Connect (LuCI)
+ PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev luci-flexibity \
+ syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
+ iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
+ usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
+ fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
+ gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
+ file flock gdbserver gnupg gpioctl gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
+ module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
+ usb-modeswitch usb-modeswitch-data usbutils lua
+endef
+
+define Profile/flexibity-luci/Description
+ Complete packages set for the Flexibity Connect device with LuCI.
+endef
+
+$(eval $(call Profile,flexibity-luci))
+
diff --git a/target/linux/at91/9260/target.mk b/target/linux/at91/9260/target.mk
new file mode 100644
index 000000000..91a1d7504
--- /dev/null
+++ b/target/linux/at91/9260/target.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2011 Flexibity
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+SUBTARGET:=9260
+BOARDNAME:=AT91SAM9260 Based board
+
+define Target/Description
+ Build images for AT91SAM9260 based board, supported board:
+ * Flexibity Connect
+endef
+