aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/at91/9260/profiles
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/at91/9260/profiles')
-rw-r--r--target/linux/at91/9260/profiles/000-flexibity-minimal.mk18
-rw-r--r--target/linux/at91/9260/profiles/001-flexibity-xwrt.mk26
-rw-r--r--target/linux/at91/9260/profiles/002-flexibity-luci.mk26
3 files changed, 70 insertions, 0 deletions
diff --git a/target/linux/at91/9260/profiles/000-flexibity-minimal.mk b/target/linux/at91/9260/profiles/000-flexibity-minimal.mk
new file mode 100644
index 000000000..f8e7a6514
--- /dev/null
+++ b/target/linux/at91/9260/profiles/000-flexibity-minimal.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 20011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/flexibity-minimal
+ NAME:=Flexibity Connect (minimal)
+ PACKAGES:=
+endef
+
+define Profile/flexibity-minimal/Description
+ Minimal packages set for the Flexibity Connect device.
+endef
+
+$(eval $(call Profile,flexibity-minimal))
+
diff --git a/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk b/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
new file mode 100644
index 000000000..b1c526929
--- /dev/null
+++ b/target/linux/at91/9260/profiles/001-flexibity-xwrt.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/flexibity-xwrt
+ NAME:=Flexibity Connect (XWrt)
+ PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev webif webif-applications webif-flexibity \
+ syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
+ iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
+ usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
+ fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
+ gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
+ file flock gdbserver gnupg gpioctl gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
+ module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
+ usb-modeswitch usb-modeswitch-data usbutils lua
+endef
+
+define Profile/flexibity-xwrt/Description
+ Complete packages set for the Flexibity Connect device (XWrt).
+endef
+
+$(eval $(call Profile,flexibity-xwrt))
+
diff --git a/target/linux/at91/9260/profiles/002-flexibity-luci.mk b/target/linux/at91/9260/profiles/002-flexibity-luci.mk
new file mode 100644
index 000000000..433239be6
--- /dev/null
+++ b/target/linux/at91/9260/profiles/002-flexibity-luci.mk
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2011-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/flexibity-luci
+ NAME:=Flexibity Connect (LuCI)
+ PACKAGES:=bridge block-mount modprobe dnsmasq hotplug2 udev luci-flexibity \
+ syslog-ng sudo transmission-web miniupnpd nmap-ssl ip ntpclient ntpdate chat crda e169-stats genl hostapd-utils \
+ iw madwimax netcat portmap ppp ppp-mod-pppoe pptp tcpdump usb-modem usb-modem-huawei-e175x usb-modem-huawei-eg162 \
+ usb-modem-nokia-5800 wpa-cli wpa-supplicant motion badblocks blkid cifsmount disktype dosfsck dosfslabel e2fsprogs \
+ fuse-utils mkdosfs nfs-utils ntfs-3g ntfs-3g-utils reiserfsprogs resize2fs sysfsutils tune2fs uuidgen certtool \
+ gnutls-utils picocom setterm unrar unzip sqlite3-cli alsa-utils anyremote bluez-utils bzip2 comgt crypto-tools \
+ file flock gdbserver gnupg gpioctl gsm-utils gzip huaweiaktbbo hwclock i2c-tools input-utils ldd lsof mdadm \
+ module-init-tools mount-utils openssl-util procps psmisc px5g screen strace stress sysstat uboot-envtools \
+ usb-modeswitch usb-modeswitch-data usbutils lua
+endef
+
+define Profile/flexibity-luci/Description
+ Complete packages set for the Flexibity Connect device with LuCI.
+endef
+
+$(eval $(call Profile,flexibity-luci))
+