aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/d-link.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/d-link.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/d-link.mk63
1 files changed, 63 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/d-link.mk b/target/linux/ar71xx/generic/profiles/d-link.mk
new file mode 100644
index 000000000..98fe00fc2
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/d-link.mk
@@ -0,0 +1,63 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DIR600A1
+ NAME:=D-Link DIR-600 rev. A1
+ PACKAGES:=
+endef
+
+define Profile/DIR600A1/Description
+ Package set optimized for the D-Link DIR-600 rev. A1.
+endef
+
+$(eval $(call Profile,DIR600A1))
+
+define Profile/DIR601A1
+ NAME:=D-Link DIR-601 rev. A1
+ PACKAGES:=
+endef
+
+define Profile/DIR601A1/Description
+ Package set optimized for the D-Link DIR-601 rev. A1.
+endef
+
+$(eval $(call Profile,DIR601A1))
+
+define Profile/DIR615C1
+ NAME:=D-Link DIR-615 rev. C1
+ PACKAGES:=
+endef
+
+define Profile/DIR615C1/Description
+ Package set optimized for the D-Link DIR-615 rev. C1.
+endef
+
+$(eval $(call Profile,DIR615C1))
+
+
+define Profile/DIR615E4
+ NAME:=D-Link DIR-615 rev. E4
+ PACKAGES:=
+endef
+
+define Profile/DIR615E4/Description
+ Package set optimized for the D-Link DIR-615 rev. E4.
+endef
+
+$(eval $(call Profile,DIR615E4))
+
+
+define Profile/DIR825B1
+ NAME:=D-Link DIR-825 rev. B1
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825B1/Description
+ Package set optimized for the D-Link DIR-825 rev. B1.
+endef
+
+$(eval $(call Profile,DIR825B1))