aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/generic/profiles/alfa.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/generic/profiles/alfa.mk')
-rw-r--r--target/linux/ar71xx/generic/profiles/alfa.mk42
1 files changed, 42 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/alfa.mk b/target/linux/ar71xx/generic/profiles/alfa.mk
new file mode 100644
index 000000000..06baf240c
--- /dev/null
+++ b/target/linux/ar71xx/generic/profiles/alfa.mk
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ALFAAP96
+ NAME:=ALFA Network AP96 board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
+endef
+
+define Profile/ALFAAP96/Description
+ Package set optimized for the ALFA Network AP96 board.
+endef
+
+$(eval $(call Profile,ALFAAP96))
+
+
+define Profile/HORNETUB
+ NAME:=ALFA Network Hornet-UB board
+ PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/HORNETUB/Description
+ Package set optimized for the ALFA Network Hornet-UB board.
+endef
+
+$(eval $(call Profile,HORNETUB))
+
+
+define Profile/ALFANX
+ NAME:=ALFA Network N2/N5 board
+ PACKAGES:=
+endef
+
+define Profile/ALFANX/Description
+ Package set optimized for the ALFA Network N2/N5 boards.
+endef
+
+$(eval $(call Profile,ALFANX))
+