aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/Makefile')
-rw-r--r--target/linux/ar71xx/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
new file mode 100644
index 000000000..f86399381
--- /dev/null
+++ b/target/linux/ar71xx/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2008-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+BOARD:=ar71xx
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=squashfs jffs2 targz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+SUBTARGETS:=generic nand
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
+ kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+ kmod-ath9k wpad-mini uboot-envtools
+
+define Target/Description
+ Build firmware images for Atheros AR7xxx/AR9xxx based boards.
+endef
+
+$(eval $(call BuildTarget))