aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar7/Makefile')
-rw-r--r--target/linux/ar7/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
new file mode 100644
index 000000000..a712d6d20
--- /dev/null
+++ b/target/linux/ar7/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=ar7
+BOARDNAME:=TI AR7
+FEATURES:=squashfs jffs2 atm
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
+ kmod-acx-mac80211 swconfig hostapd
+
+define Target/Description
+ Build firmware images for TI AR7 based routers.
+endef
+
+$(eval $(call BuildTarget))