aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/patches-3.3
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm8668/patches-3.3')
-rw-r--r--target/linux/adm8668/patches-3.3/001-adm8668_arch.patch39
-rw-r--r--target/linux/adm8668/patches-3.3/002-adm8668_uart.patch40
-rw-r--r--target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch25
3 files changed, 104 insertions, 0 deletions
diff --git a/target/linux/adm8668/patches-3.3/001-adm8668_arch.patch b/target/linux/adm8668/patches-3.3/001-adm8668_arch.patch
new file mode 100644
index 000000000..c00188cf0
--- /dev/null
+++ b/target/linux/adm8668/patches-3.3/001-adm8668_arch.patch
@@ -0,0 +1,39 @@
+--- a/arch/mips/Kbuild.platforms
++++ b/arch/mips/Kbuild.platforms
+@@ -30,6 +30,7 @@ platforms += sni
+ platforms += txx9
+ platforms += vr41xx
+ platforms += wrppmc
++platforms += adm8668
+
+ # include the platform specific files
+ include $(patsubst %, $(srctree)/arch/mips/%/Platform, $(platforms))
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -105,6 +105,26 @@ config BCM47XX
+ help
+ Support for BCM47XX based boards
+
++config ADM8668
++ bool "WildPass ADM8668"
++ select SYS_HAS_CPU_MIPS32_R1
++ select BOOT_RAW
++ select NO_EXCEPT_FILL
++ select IRQ_CPU
++ select CEVT_R4K
++ select CSRC_R4K
++ select HW_HAS_PCI
++ select PCI
++ select SYS_SUPPORTS_LITTLE_ENDIAN
++ select SYS_SUPPORTS_32BIT_KERNEL
++ select DMA_NONCOHERENT
++ select SWAP_IO_SPACE
++ select SERIAL_ADM8668
++ select SERIAL_ADM8668_CONSOLE
++ help
++ ADM8668 board support by neutronscott
++ Scott Nicholas <neutronscott@scottn.us>
++
+ config BCM63XX
+ bool "Broadcom BCM63XX based boards"
+ select CEVT_R4K
diff --git a/target/linux/adm8668/patches-3.3/002-adm8668_uart.patch b/target/linux/adm8668/patches-3.3/002-adm8668_uart.patch
new file mode 100644
index 000000000..ed55cbbaa
--- /dev/null
+++ b/target/linux/adm8668/patches-3.3/002-adm8668_uart.patch
@@ -0,0 +1,40 @@
+--- a/drivers/tty/serial/Kconfig
++++ b/drivers/tty/serial/Kconfig
+@@ -1192,6 +1192,25 @@ config SERIAL_BCM63XX_CONSOLE
+ If you have enabled the serial port on the bcm63xx CPU
+ you can make it the console by answering Y to this option.
+
++config SERIAL_ADM8668
++ tristate "ADM8668 serial port support"
++ select SERIAL_CORE
++ depends on ADM8668
++ help
++ If you have an adm8668 CPU, you can enable its onboard
++ serial port by enabling this options.
++
++ To compile this driver as a module, choose M here: the
++ module will be called adm8668_uart.
++
++config SERIAL_ADM8668_CONSOLE
++ bool "Console on adm8668 serial port"
++ depends on SERIAL_ADM8668=y
++ select SERIAL_CORE_CONSOLE
++ help
++ If you have enabled the serial port on the adm8668 CPU
++ you can make it the console by answering Y to this option.
++
+ config SERIAL_GRLIB_GAISLER_APBUART
+ tristate "GRLIB APBUART serial support"
+ depends on OF && SPARC
+--- a/include/linux/serial_core.h
++++ b/include/linux/serial_core.h
+@@ -211,6 +211,9 @@
+ #define PORT_AR933X 99
+
+
++/* ADM8668 UART */
++#define PORT_ADM8668 100
++
+ #ifdef __KERNEL__
+
+ #include <linux/compiler.h>
diff --git a/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch b/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch
new file mode 100644
index 000000000..eca9bc468
--- /dev/null
+++ b/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -96,6 +96,12 @@ config MSP_FLASH_MAP_LIMIT
+ default "0x02000000"
+ depends on MSP_FLASH_MAP_LIMIT_32M
+
++config MTD_ADM8668_NOR
++ tristate "ADM8668 NOR mapping"
++ depends on ADM8668 && MTD_CFI
++ help
++ mapping driver for ADM8668 NOR
++
+ config MTD_SUN_UFLASH
+ tristate "Sun Microsystems userflash support"
+ depends on SPARC && MTD_CFI && PCI
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += map_funcs.o
+ endif
+
+ # Chip mappings
++obj-$(CONFIG_MTD_ADM8668_NOR) += adm8668.o
+ obj-$(CONFIG_MTD_CDB89712) += cdb89712.o
+ obj-$(CONFIG_MTD_CFI_FLAGADM) += cfi_flagadm.o
+ obj-$(CONFIG_MTD_DC21285) += dc21285.o