aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch')
-rw-r--r--target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch b/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch
new file mode 100644
index 000000000..eca9bc468
--- /dev/null
+++ b/target/linux/adm8668/patches-3.3/003-adm8668_nor_map.patch
@@ -0,0 +1,25 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -96,6 +96,12 @@ config MSP_FLASH_MAP_LIMIT
+ default "0x02000000"
+ depends on MSP_FLASH_MAP_LIMIT_32M
+
++config MTD_ADM8668_NOR
++ tristate "ADM8668 NOR mapping"
++ depends on ADM8668 && MTD_CFI
++ help
++ mapping driver for ADM8668 NOR
++
+ config MTD_SUN_UFLASH
+ tristate "Sun Microsystems userflash support"
+ depends on SPARC && MTD_CFI && PCI
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -7,6 +7,7 @@ obj-$(CONFIG_MTD) += map_funcs.o
+ endif
+
+ # Chip mappings
++obj-$(CONFIG_MTD_ADM8668_NOR) += adm8668.o
+ obj-$(CONFIG_MTD_CDB89712) += cdb89712.o
+ obj-$(CONFIG_MTD_CFI_FLAGADM) += cfi_flagadm.o
+ obj-$(CONFIG_MTD_DC21285) += dc21285.o