aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm8668/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm8668/Makefile')
-rw-r--r--target/linux/adm8668/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
new file mode 100644
index 000000000..8ad2e71ea
--- /dev/null
+++ b/target/linux/adm8668/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=adm8668
+BOARDNAME:=Infineon WildPass ADM8668
+FEATURES:=squashfs
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+LINUX_VERSION:=3.3.8
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
+# kmod-switch kmod-diag nvram
+
+define Target/Description
+ Build firmware images for Infineon WildPass (ADM8668) based routers
+ (e.g. T-Mobile branded Linksys WRTU54G-TM)
+endef
+
+$(eval $(call BuildTarget))