aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/patches-3.3/120-rb153_cf_driver.patch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/patches-3.3/120-rb153_cf_driver.patch')
-rw-r--r--target/linux/adm5120/patches-3.3/120-rb153_cf_driver.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/adm5120/patches-3.3/120-rb153_cf_driver.patch b/target/linux/adm5120/patches-3.3/120-rb153_cf_driver.patch
new file mode 100644
index 000000000..cc2caf5a3
--- /dev/null
+++ b/target/linux/adm5120/patches-3.3/120-rb153_cf_driver.patch
@@ -0,0 +1,28 @@
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -88,6 +88,7 @@ obj-$(CONFIG_PATA_PCMCIA) += pata_pcmcia
+ obj-$(CONFIG_PATA_PALMLD) += pata_palmld.o
+ obj-$(CONFIG_PATA_PLATFORM) += pata_platform.o
+ obj-$(CONFIG_PATA_OF_PLATFORM) += pata_of_platform.o
++obj-$(CONFIG_PATA_RB153_CF) += pata_rb153_cf.o
+ obj-$(CONFIG_PATA_RB532) += pata_rb532_cf.o
+ obj-$(CONFIG_PATA_RZ1000) += pata_rz1000.o
+ obj-$(CONFIG_PATA_SAMSUNG_CF) += pata_samsung_cf.o
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -835,6 +835,15 @@ config PATA_QDI
+ help
+ Support for QDI 6500 and 6580 PATA controllers on VESA local bus.
+
++config PATA_RB153_CF
++ tristate "RouterBOARD 153 Compact Flash support"
++ depends on ADM5120_MACH_RB_153
++ help
++ This option enables support for a Compact Flash connected on
++ the RouterBOARD 153.
++
++ If unsure, say N.
++
+ config PATA_RB532
+ tristate "RouterBoard 532 PATA CompactFlash support"
+ depends on MIKROTIK_RB532