aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/adm5120/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/adm5120/Makefile')
-rw-r--r--target/linux/adm5120/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
new file mode 100644
index 000000000..273a28093
--- /dev/null
+++ b/target/linux/adm5120/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2007-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+BOARD:=adm5120
+BOARDNAME:=Infineon/ADMtek ADM5120
+LINUX_VERSION:=3.3.8
+SUBTARGETS:=router_le router_be rb1xx
+INITRAMFS_EXTRA_FILES:=
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+ kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+ kmod-leds-gpio kmod-ledtrig-adm5120-switch
+
+$(eval $(call BuildTarget))