aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/files/board/arcadyan/config.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/uboot-lantiq/files/board/arcadyan/config.mk')
-rw-r--r--package/uboot-lantiq/files/board/arcadyan/config.mk36
1 files changed, 36 insertions, 0 deletions
diff --git a/package/uboot-lantiq/files/board/arcadyan/config.mk b/package/uboot-lantiq/files/board/arcadyan/config.mk
new file mode 100644
index 000000000..cc8cd3090
--- /dev/null
+++ b/package/uboot-lantiq/files/board/arcadyan/config.mk
@@ -0,0 +1,36 @@
+#
+# (C) Copyright 2003
+# Wolfgang Denk, DENX Software Engineering, wd@denx.de.
+#
+# See file CREDITS for list of people who contributed to this
+# project.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2 of
+# the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston,
+# MA 02111-1307 USA
+#
+sinclude $(OBJTREE)/board/$(BOARDDIR)/config.tmp
+
+ifdef CONFIG_BOOTSTRAP
+TEXT_BASE = 0x80001000
+CONFIG_BOOTSTRAP_TEXT_BASE = 0xb0000000
+CONFIG_SYS_RAMBOOT = y
+else
+
+ifndef TEXT_BASE
+$(info redefine TEXT_BASE = 0xB0000000 )
+TEXT_BASE = 0xB0000000
+endif
+
+endif