aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/patches/106-get_arch.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/madwifi/patches/106-get_arch.patch')
-rw-r--r--package/madwifi/patches/106-get_arch.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/madwifi/patches/106-get_arch.patch b/package/madwifi/patches/106-get_arch.patch
new file mode 100644
index 000000000..3140f3679
--- /dev/null
+++ b/package/madwifi/patches/106-get_arch.patch
@@ -0,0 +1,21 @@
+--- a/scripts/get_arch.mk
++++ b/scripts/get_arch.mk
+@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
+ $(Cannot determine ARCH)
+ endif
+
++# Allow ARCH to be x86
++ifneq (,$(CONFIG_X86))
++ifeq (x86,$(ARCH))
++ARCH-y = $(ARCH)
++endif
++endif
++
+ # Don't allow ARCH to be overridden by a different value.
+ ifeq (,$(ARCH))
+ ARCH = $(ARCH-y)
+-else
+-ifneq ($(ARCH),$(ARCH-y))
+-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
+-endif
+ endif